Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
04-14-2018, 04:10 PM,
#1
Turn Signal Issues
Recently bought a 98 650. It has the headlight with built in turn signals. The rear turn signals were replaced with LED bullet style. With low beams on the rears act like running lights and both rear left and right come on. BUT all (front and rear left) turn signals only work with the high beam on. My rear right doesn't work at all (only works being a running light in low beam). I dont know how previous owner wired these and I'm not very knowledgeable in this area. Any ideas or suggestions would be greatly appreciated.


Attached Files Thumbnail(s)
   
Reply
Possibly Related Threads...
Thread Author Replies Views Last Post
  fuel issues dnelson65 1 128 06-04-2018, 12:19 AM
Last Post: dnelson65
  How to disconnect front turn signal wires Holtmann 3 394 03-14-2018, 11:43 AM
Last Post: Holtmann
  Help!! I have no turn signals at all!! mikeinflo 0 1,128 03-09-2017, 08:47 PM
Last Post: mikeinflo
  wiped out and busted signal light. Stormlady 11 2,738 08-22-2015, 09:02 PM
Last Post: Stormlady
  Installed LED turn signals, now no speedo hckycoz 3 1,718 02-08-2015, 04:29 PM
Last Post: OldePhart
  Turn signals are funky rvader 4 1,827 12-15-2014, 11:35 PM
Last Post: OldePhart
  Turn signals cancelling stantheman 14 6,896 10-02-2014, 09:55 AM
Last Post: OldePhart
  throttle issues jono6888 12 3,422 07-22-2014, 07:58 PM
Last Post: ET_Geckoe
  Found some decent compact LED turn signals. OldePhart 22 7,826 07-12-2014, 08:50 PM
Last Post: Mr RCOM
  LED turn signals = load resistors or Flasher Maustarman 6 8,331 06-22-2014, 03:20 PM
Last Post: OldePhart

Users browsing this thread:
1 Guest(s)