Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
04-07-2015, 03:31 PM,
#1
Help with LED Turn Signals
I just got a 2004 v star 1100 Classic and it has these aftermarket turn signals installed, the issue is when the switch is engaged no indicator light comes on in the dash panel, the signals seem to me are flashing fast, AND no matter if I select left or right all 4 flash as if it's 4 way emergency flashers on a car. Looking for a place to start, perhaps grounding problem?


Attached Files Thumbnail(s)
   
Reply
04-07-2015, 03:41 PM, (This post was last modified: 04-07-2015, 03:42 PM by OldePhart.)
#2
RE: Help with LED Turn Signals
Take the bulb out of the turn signal indicator in the instrument cluster. This will not fix rapid flashing, but will fix the crossover. I could give you a long, technical explanation why but you probably wouldn't be interested. :)

You can put diodes in the indicator circuit to fix the crossover also, but that is a lot of work for not much benefit because the stupid indicator light is useless.
===========================
2011 V-Star 650 Custom (new in fall 2013)
V&H Cruzer Pipes, Memphis Shades Bat Wing, Floorboards, Highway Bars,
Locking Bags, Tail Rack, LED Signals & Aux Brake Lights, Headlight Modulator,
Brake Light Modulator, 5/8" Gel Pad Under Upholstery.
Reply
04-07-2015, 06:02 PM,
#3
Help with LED Turn Signals
(04-07-2015, 03:31 PM)Hacksaw Wrote: I just got a 2004 v star 1100 Classic and it has these aftermarket turn signals installed, the issue is when the switch is engaged no indicator light comes on in the dash panel, the signals seem to me are flashing fast, AND no matter if I select left or right all 4 flash as if it's 4 way emergency flashers on a car. Looking for a place to start, perhaps grounding problem?

Here is a Video I made on how to solve those problems by modifying your stock relay
http://youtu.be/gO-lWWGhEgw
Reply
04-08-2015, 06:57 PM,
#4
RE: Help with LED Turn Signals
OldePhart I took the bulb out and as you said they are no longer crossover. The flash rate isn't too bad, It's tolerable.

Maustarman I watched your vid and will do that soon as a permanent solution.

Thanks to you both for your words of wisdom :)
Reply
04-09-2015, 08:41 AM,
#5
RE: Help with LED Turn Signals
(04-08-2015, 06:57 PM)Hacksaw Wrote: OldePhart I took the bulb out and as you said they are no longer crossover. The flash rate isn't too bad, It's tolerable.

Maustarman I watched your vid and will do that soon as a permanent solution.

Thanks to you both for your words of wisdom :)

Hacksaw - I have spare resistors for Maustarman's flasher mod - send me a pm with your snailmail address if you want one
2007 V-Star Classic
Hard-Krome Straights, Mustang seat and backrest, 4" risers,
4" control extensions, LED headlamp, LED tail/brake light board, LED rear running light/brake/turn signals, LED front running lights/turn signals, brake light modulator, Stebel air horn, tank bra, EasyBrackets

Reply
04-09-2015, 03:47 PM,
#6
RE: Help with LED Turn Signals
Does removing the indicator bulb effect the auto turn signal cancelling feature??
08 650 Classic. PIAA headlight w/CD Modulator, CD Brakelight LED Modulator Strips. Superbright LED brake lights. Engine guard w/highway pegs. Some hard saddle bags and driving lights and whatever i buy today and put on after the mailman delivers it.
Reply
04-09-2015, 04:11 PM,
#7
RE: Help with LED Turn Signals
(04-09-2015, 03:47 PM)kenstogie Wrote: Does removing the indicator bulb effect the auto turn signal cancelling feature??

No
===========================
2011 V-Star 650 Custom (new in fall 2013)
V&H Cruzer Pipes, Memphis Shades Bat Wing, Floorboards, Highway Bars,
Locking Bags, Tail Rack, LED Signals & Aux Brake Lights, Headlight Modulator,
Brake Light Modulator, 5/8" Gel Pad Under Upholstery.
Reply
04-09-2015, 05:25 PM,
#8
RE: Help with LED Turn Signals
thats the kuryakyn tombstone new version, pretty pricey setup, i have old one and still fighting to get turn signal mounted, thats just the 1 that came off. guess would be easier as others said if could get the entire system off the bike but with hours of attempt and 2 shade tree bike mechs was a no go. turn signal is a self ground as there is no ground wire, so since do not have it all the way to the brake light housing, it does not function, but the brake flashes now when am turning right and did not have to buy the flashing mod for it.
2006 VStar Stratoliner, Freedom Performance split dual exhaust, Mustang seats, Sissy bar with back rack, bolted saddlebags to mounts.
Life's tough .. it's even tougher if you're stupid. - John Wayne

Reply
04-09-2015, 09:54 PM,
#9
RE: Help with LED Turn Signals
(04-09-2015, 08:41 AM)Blackacre1066 Wrote:
(04-08-2015, 06:57 PM)Hacksaw Wrote: OldePhart I took the bulb out and as you said they are no longer crossover. The flash rate isn't too bad, It's tolerable.

Maustarman I watched your vid and will do that soon as a permanent solution.

Thanks to you both for your words of wisdom :)

Hacksaw - I have spare resistors for Maustarman's flasher mod - send me a pm with your snailmail address if you want one
I appreciate the offer, I stopped by a TV Repair Shop (yes one still exists around here) and the guy gave me nearly a handful for two bucks
Reply
04-11-2015, 07:05 AM,
#10
Help with LED Turn Signals
If you wire one of these kits in behind your speedo you can keep your dash bulb and you don't need any resistors - just an led relay
https://www.superbrightleds.com/moreinfo...1190/2805/
Easy to wire in and solder in. Works a treat.


Sent from my iPad using Tapatalk
Reply
04-19-2015, 04:53 PM,
#11
RE: Help with LED Turn Signals
ok Fellas, once I figured out where the relay was and getting it out with my fat stubby fingers I did the resistor mod, that in fact did cure the hyperflashing, I've ordered the diode kit so I can use the indicator bulb again.
Reply
04-24-2015, 08:57 PM,
#12
RE: Help with LED Turn Signals
Mission complete. I got the diode kit and soldered in today, put bulb back in and everything works as it should. Thanks everyone for your input!
Reply
04-24-2015, 08:59 PM,
#13
Help with LED Turn Signals
I love this Mod :)
Glad you got everything running
Reply
05-01-2015, 09:36 AM, (This post was last modified: 05-01-2015, 09:41 AM by B2LL2F.)
#14
Help with LED Turn Signals
(04-24-2015, 08:57 PM)Hacksaw Wrote: Mission complete. I got the diode kit and soldered in today, put bulb back in and everything works as it should. Thanks everyone for your input!

Nice work


Sent from my iPad using Tapatalk

I recently changed my indicators again.
I changed out the broken LEDs to some eBay ones but they were shit house- big and I didn't mind the look and shape but the light & brightness were just garbage. They were cheap so to be expected.
[Image: 5939eafab8a95ff96461396864ac85e0.jpg]

Then I changed to small LEDs - which I like but they didn't suit the vstar- so they'll end up on my other bike.
So I changed to these Oxford LEDs for the Vstar. Really good quality and super bright- near blinding. And the shape is odd but I like it for the vstar.
[Image: 9bd83ac0e7b12887df93b23d760e39b4.jpg]
[Image: 37becf9eb9ddf45885fa91cedc9ff718.jpg]


Sent from my iPad using Tapatalk
Reply
07-15-2019, 12:21 PM,
#15
RE: Help with LED Turn Signals
Can anyone confirm that I only need 1 diode kit for a 99' v start 650 (I only have one indicator bulb). This documentation below (link) is good for the install, but it mentions using 2 diodes, any everything I'm reading in other areas / posts mentions only using 1. Is that because his/her particular setup has 2 indicator bulbs (possibly?) Thanks for any insight!

650ccnd. com/pdfs/VStar650DiodeMod. pdf

Thanks,
-MD
Reply
Possibly Related Threads...
Thread Author Replies Views Last Post
  MISS FIRE ON ACELL HELPS SOME IF YOU TURN THE CHOKE ON. bad69stanginmo 14 8,422 10-21-2015, 12:07 PM
Last Post: Maustarman
  Turn much? ET_Geckoe 11 5,945 05-19-2014, 12:37 AM
Last Post: Star Rider
  Poor Man's Bobber Signals Cambo 3 3,635 10-25-2013, 12:12 AM
Last Post: Mr RCOM
  Turn Signals Magnuts 9 6,538 10-07-2013, 02:14 AM
Last Post: Wallaby
  Turn signal light bulb ET_Geckoe 14 16,624 06-29-2013, 02:20 AM
Last Post: ET_Geckoe

Users browsing this thread:
1 Guest(s)