Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
07-07-2015, 02:38 PM,
#16
RE: Hard to start
Ive not heard the pump prime or anything until I started it with the cover off yesterday and it was running. I used to hear it every time I turned the key on after it sat during the day.
Reply
07-07-2015, 03:52 PM,
#17
RE: Hard to start
do you switch your petcock to the off position when you shut down?
'07 Double One Hundred Custom Black Cherry w/Ghost flames
Cobra Speedster Slashdown pipes
Barons ORK
Disabled AIS
Cobra Carb Needles
Every cage is trying to kill you so always remember, Grip it and Rip it!!!

Reply
07-07-2015, 06:12 PM,
#18
RE: Hard to start
(07-07-2015, 02:38 PM)stantheman Wrote: Ive not heard the pump prime or anything until I started it with the cover off yesterday and it was running. I used to hear it every time I turned the key on after it sat during the day.
i'm not sure what stops the pump after 10 seconds when not running but the key on.. that could be the problem. i know that i cant hear the pump with the engine running, are you sure it the pump your hearing. i'v put a test light to pumps before to see when power is going to it when the engine is running
Reply
07-09-2015, 10:37 AM,
#19
RE: Hard to start
Havent ever turned off the petcock when parked.
Reply
09-13-2016, 07:50 PM,
#20
RE: Hard to start
Hi guys. I'm having issues with my 2007 650 starting when it's cold that's decided to play up this past few weeks. When it's hot runs like a charm and you wouldn't believe there was an issue. Start first time every time when hot. It's just the dreaded initial cold start that's bugging right off. Here's what I've done so far. 1) remove and replace carbs to fully clean out, check floats and set all carbs to spec as per workshop manual inc balance and mixture screws. 2) check valve adjustment all good and set to spec. 3) New plugs. 4) new fuel filer. 5) new air filter. The fuel pump runs and stops ready to start. Oil level all good. carbs needle and seat doesn't appear to be leaking when closed. To start, choke in throttle half to 3/4 and hit start button. winds over for approx. 5 maybe 10 sec and starts. Before, I would set choke to first notch hit button and starts straight away. I'm in Australia so no snow or anything, quite the opposite. Any help would be great as I'm at the end of my wits here and ready to burn the thing lol!
Reply
Possibly Related Threads...
Thread Author Replies Views Last Post
Bullet_wrench Help. V Star 1300 will not start! MotoMike 3 1,352 06-30-2016, 04:12 PM
Last Post: Elk
  How hard is it to replace bar end caps? OldePhart 6 1,399 07-20-2014, 03:25 PM
Last Post: commonground
  Start Early Knucklehead 7 1,550 04-14-2013, 10:11 PM
Last Post: Matt

Users browsing this thread:
1 Guest(s)