Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
08-27-2016, 04:32 PM,
#1
Starting issues
Cut to yesterday leaving work.

Systems aligned ready to rock. Hit the starter and it just spins doesn't even attempt to sound like it is engaged. tried again, same. #@$%!!. Push started and checked it out at home. other than a bit of carbon build up, starter appears good. reinstalled, had a hall of a time getting it to slide in until I thought to shift into second ( i read somewhere that this engages the sprag clutch, whatever, it worked went right into place) so systems realigned and here we...chug-zz-ghug-zzzz-chug-zzzz. thoughts?
'07 Double One Hundred Custom Black Cherry w/Ghost flames
Cobra Speedster Slashdown pipes
Barons ORK
Disabled AIS
Cobra Carb Needles
Every cage is trying to kill you so always remember, Grip it and Rip it!!!

Reply
09-04-2016, 09:26 PM,
#2
RE: Starting issues
Found it. It's the starter clutch.

Sent from my SAMSUNG-SM-G890A using Tapatalk
'07 Double One Hundred Custom Black Cherry w/Ghost flames
Cobra Speedster Slashdown pipes
Barons ORK
Disabled AIS
Cobra Carb Needles
Every cage is trying to kill you so always remember, Grip it and Rip it!!!

Reply
Possibly Related Threads...
Thread Author Replies Views Last Post
  Turn signal issues with 2004 V Star 1100 Bilzer 2 675 07-03-2016, 07:42 PM
Last Post: pauli466
  starting issue jfrechette 1 532 02-23-2016, 09:51 PM
Last Post: pauli466
  turn signal issues jfrechette 6 1,232 08-17-2015, 08:18 AM
Last Post: pauli466
Bullet_wrench Battery or Electrical Issues?? Trujeepr 8 4,000 03-14-2013, 05:26 AM
Last Post: Mr RCOM

Users browsing this thread:
1 Guest(s)