Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
09-23-2016, 10:10 AM,
2009 vstar 950 major lean fuel issue.
Guys, need some help with a lean fuel problem.

Looking to buy for my dad so he can ride with us. It has only 1100
miles, and has brand new cobra speedster slashdown pipes. The previous
owner does not have the OEM exhaust.

It start up perfect all the time, idles perfect, but does not accelerate
well. You cannot get above 30MPH the engine starts to stumble and want
to cut out like it is too lean.

We installed a 22-009 power commander V and tried a bunch of mappings
with no success. I uplugged the 02 sensor and it only gave me a few MPH
increase before it stumbles again. Owner put new plugs in it and fresh
90 octane fuel with no change. Fuel pump sounds really good, no gurgle
or cavitation sounds, not fuel leaks, we are totally stumped.
11-27-2016, 03:42 PM, (This post was last modified: 11-27-2016, 03:46 PM by Batman.)
RE: 2009 vstar 950 major lean fuel issue.
I would check the air filter first. Sounds like she can't breath.

Is it throwing a trouble code?
Possibly Related Threads...
Thread Author Replies Views Last Post
  2009 950 vstar belt squeaking / pulley ? 308winchester 13 6,710 01-30-2018, 04:55 PM
Last Post: theaslanskid
  Fuel Tank wobble ats9585 5 2,115 11-27-2016, 04:20 PM
Last Post: Batman
  How far can I go without a fuel mod? 09950ccVStar 5 2,404 03-07-2016, 12:22 AM
Last Post: YamaMassGirl
  2009 V-star not needed. shepsv-star 29 10,411 08-11-2013, 08:58 PM
Last Post: OldePhart
  V-star running lean? RemoteCntrl 8 5,761 09-01-2012, 12:45 AM
Last Post: jmck

Users browsing this thread:
1 Guest(s)