Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
03-09-2017, 08:47 PM,
#1
Help!! I have no turn signals at all!!
Hello All. I have a 2005 yamaha v star 650 and I have no turn signals at all. I have found the wires and BLACK is ground, BLUE is key on, BROWN and GREEN are the signals. But when I hook up the wires from the signals I have nothing. I even bought a new relay and still nothing. IM IN NEED FOR SOME HELP!!
Reply
Possibly Related Threads...
Thread Author Replies Views Last Post
  Turn Signal Issues mlawson 0 249 04-14-2018, 04:10 PM
Last Post: mlawson
  How to disconnect front turn signal wires Holtmann 3 475 03-14-2018, 11:43 AM
Last Post: Holtmann
  any way to make front signals flash on and off rather than dim and bright? Herubinr38 3 1,906 05-26-2016, 08:16 AM
Last Post: huntpro13
  Installed LED turn signals, now no speedo hckycoz 3 1,781 02-08-2015, 04:29 PM
Last Post: OldePhart
  Turn signals are funky rvader 4 1,920 12-15-2014, 11:35 PM
Last Post: OldePhart
  Turn signals cancelling stantheman 14 7,120 10-02-2014, 09:55 AM
Last Post: OldePhart
  Strange Spark Signals indie_rocker 6 2,034 08-18-2014, 07:07 PM
Last Post: indie_rocker
  Found some decent compact LED turn signals. OldePhart 22 8,128 07-12-2014, 08:50 PM
Last Post: Mr RCOM
  LED turn signals = load resistors or Flasher Maustarman 6 8,591 06-22-2014, 03:20 PM
Last Post: OldePhart
  DPDT Toggle switch for Turn Signals... Help! Maustarman 3 2,729 12-18-2013, 07:40 PM
Last Post: colonel

Users browsing this thread:
1 Guest(s)