Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
09-18-2017, 08:58 PM,
#1
Oil change now it won't stay running
I have a 1999 650 V star. I changed the oil and now it won't stay running I used Castro 20/50 4 t motor cycle oil and a napa oil filter # 4936 which they is compatable with it . I love to ride it's a wonderful bike and I need it to run right. Thanks in advance for all the help.
Reply
09-20-2017, 07:44 AM,
#2
RE: Oil change now it won't stay running
An oil change in itself should not be the cause of your troubles... at least there's no logical reason I can come up with unless the bike has an oil pressure sensor that cuts the ignition if there isn't any oil pressure. How long after starting before it cuts out? Do you start it with the choke on or off? Have you checked the fuel flow at the petcock? If you could provide, in detail, what occurs we may be better able to offer suggestions. If you could post a vid that would be really helpful.
Reply
Possibly Related Threads...
Thread Author Replies Views Last Post
  Not running on rear cylinder Florida_Rider 3 1,967 12-15-2016, 11:02 PM
Last Post: nick59
  high idle and only stays running with open choke Twizzler 18 4,970 04-11-2015, 10:31 PM
Last Post: Twizzler
  How often do you change your spark plugs? DroidBot 10 8,758 08-08-2014, 10:16 AM
Last Post: commonground
  Vstar Running Lean Help Maustarman 4 2,341 01-04-2014, 11:19 PM
Last Post: OldePhart
  Road Trip Oil Change, again… VStar King 0 1,176 04-23-2012, 09:48 AM
Last Post: VStar King
  V Star 650 oil change disaster VStar King 0 1,653 04-22-2012, 06:52 PM
Last Post: VStar King

Users browsing this thread:
1 Guest(s)